Violación de segmento en el analizador de uso de disco

abril 8, 2009 en 6:33 PM | Publicado en Consejos y utilidades | 1 comentario
Etiquetas: , , , , , , ,

En las distribuciones GNU/Linux que usan GNOME como su entorno de escritorio predeterminado (leáse Debian, Linux Mint o Ubuntu), la herramienta predeterminada que sirve para analizar nuestro disco duro y saber el tamaño que ocupa cada carpeta es baobab, aunque dentro de GNOME nunca es llamada por ése nombre, siendo más bien el “Analizador de uso de disco”.

pantallazo-analizador-de-uso-de-disco

Esta aplicación, como se puede suponer, hace un escaneo de las carpetas o unidades que especifiquemos y nos muestra con un gráfico muy intuitivo cuáles son las que ocupan más espacio en la unidad y su estructura.

Toda esta cátedra viene a cuento por que últimamente he estado usando mucho dicho programa, puesto que ando en el proceso clásico de las copias de seguridad. Y claro, me es muy útil para saber qué directorios ocupan más y qué es lo que tienen, para que el backup no crezca hasta dimensiones estratosféricas.

Por eso me quedé demasiado mosqueado cuando hace unos momentos, de buenas a primeras, la aplicacioncita de marras no quiso arrancar. O bueno, debería decir que arrancó, pero se cerró instantáneamente. Como cualquiera que tenga dos dedos de frente y use GNU/Linux o BSD o cualquier otro *NIX, intenté iniciar el programa desde consola, que siempre es lo mejor para saber de posibles fallos. Pues va, que lo intento iniciar y me tira lo siguiente:

kureno@LunaNueva:~$ baobab
Violación de segmento

¡Hala! Vamos bien. Una violación de segmento.  Y nada más para saber qué demonios ocurre. Ya puestos, sigue lo clásico: intentar desinstalar y reinstalar el programa. Vamos a Synaptic (o desde consola, da igual) y nos damos cuenta de que el paquete ‘baobab‘ no está. Buscamos más y descubrimos que dicha herramienta está, pero dentro del metapaquete gnome-utils. Pues hala, a reinstalar. Terminamos y nos damos cuenta de que sigue igual. Mola.

Veamos, ¿qué más podemos intentar? ¡Ya sé! Veamos si podemos iniciarlo como root. Nuevamente desde consola y usando su o sudo, vemos que si funciona, por lo que es concluyente que no es un fallo del programa. Si lo fuera, no arrancaría con ningún usuario. Entonces… ¿qué puede ser?

Pensando un poco (o un mucho, depende, es usar razonamiento deductivo =3), llegamos a la conclusión de que lo único que diferencia el comportamiento de un programa entre varios usuarios es la configuración personal. Es decir, que de forma intencionada o no, algo le movimos a nuestra configuración personal que hace que el programa tenga error. ¿Qué hacer?

Existen varias rutas y dependen de la aplicación en cuestión. Si el programa se puede reconfigurar desde la línea de comandos, pues nos tocará leernos el man y ver si encontramos algo. O borrar el directorio asociado (y oculto) de nuestra carpeta personal. O buscar en la Herramienta de configuración, que en este caso en particular, es lo que funciona.

Abrimos dicha herramienta con un Alt + F2 y escribimos gconf-editor. Ahora, navegamos hasta /apps/baobab/properties y buscamos el valor skip_scan_uri_list en el lado derecho:

pantallazo-editor-de-configuracion-properties

Doble clic y en la siguiente ventana seleccionamos el valor file:/// y con el botón Quitar, lo eliminamos:

pantallazo-editar-la-clave

Cerramos todo e intentamos iniciar el Analizador de nuevo. Si todo se hizo bien, pues ya debe de funcionar. Ahora, no olvidéis apuntar esta solución, que seguro les puede pasar de nuevo ;-).

Nos vemos.

Anuncios

Así me siento tranquilo

enero 17, 2009 en 11:49 PM | Publicado en Sucesos, Webroll | Deja un comentario
Etiquetas: , , ,

El otro día estaba buscando cierta información relacionada ya no me acuerdo con qué, cuando, al introducir una dirección, en vez de llevarme a sitio que supuse me llevaría, me cargó el siguiente anuncio:

Antivirus 2009

Vamos, que luego de eso, sin importar qué opción le diera, me pasó a la siguientes página:

¡Yey!

¡Yey!

¡Wiii!

¡Wiii!

Vaya. Así ni quien se sienta inseguro en este mundo digital. Y faltaba lo mejor:

Ni quien diga nada...

Ni quien diga nada...

Qué amables. Además de escanear mi sistema gratuitamente, me ofrecen un solución de seguridad. Lo dicho, así ni quien tenga miedo de los malvados ‘viruses’ y los trayanos que pululan en la red.

Pero afortunadamente para mí, y desafortunadamente para estos señores, yo uso Debian GNU/Linux y vivo feliz así. OK. Sé que no soy el primero al que le ocurre esto, pero sí que es la primera vez que me sale un ‘escaneo’ de éste tipo estando en mi Debian.

Me siento feliz 🙂 .

Actualizando el Twitter desde terminal en GNU/Linux

noviembre 24, 2008 en 1:31 AM | Publicado en Consejos y utilidades, Liberación digital, Linux Shell, Software bits | 1 comentario
Etiquetas: , , , , ,

Bueno, creo que el asunto del post en sí está algo trillado, puesto que ya desde hace tiempo que es posible actualizar el Twitter desde la línea de comandos en GNU/Linux. De hecho, hoy que estaba haciendo una búsqueda me encontré varias páginas que ponen instrucciones sobre cómo hacerlo. No obstante, la forma que postean no es que me agradara mucho, puesto que hay que bajar un script de fuera de los repositorios, y hay que invocarlo desde la carpeta donde esté guardado para poder usarlo.

Por lo tanto, me puse a investigar bien. Una búsqueda rápida por el Synaptic demostró ser mejor y me encontré con una utilidad mucho mejor y más sencilla. El nombre del paquete: python-twyt.

A diferencia de otras soluciones, Twyt se me hizo extremadamente sencillo. Leyéndose el man y con ayuda del comando

$ twyt --commands

sabremos muy bien cómo manejar el cliente. En sí es muy sencillo. Primero nos autenticamos:

$ twyt savepass -u USUARIO

con lo que nos pedirá la contraseña, misma que guardará en un archivo oculto, en nuestro Home: .twytrc. Hecho esto, podemos mandar un nuevo Tweet:

$ twyt tweet MENSAJE

Podemos ver nuestra línea de tiempo (timeline):

$ twyt usertl

Ver los 20 tweets más recientes nuestros y de nuestros amigos:

$ twyt friendtl

Borrar uno de nuestros mensajes:

$ twyt delete ID_DEL_MENSAJE

Y muchas otras cosas. Como dije antes, el programa es muy sencillo y al menos para las cosas básicas nos puede servir perfectamente. Además, la sintaxis es muy simple también. Repito, lo mejor para saber bien el funcionamiento es leerse el manual (man) y revisar la lista de comandos permitidos. Y si ya lo hicieron, pues ¿a qué esperan? A twittear de la forma más geek posible 😉 .

Un problema lleva a otro

junio 20, 2008 en 12:49 AM | Publicado en Debian, Liberación digital, OMG, Sucesos | 3 comentarios
Etiquetas: , , , , , , , ,

Antier, mientras estaba pensando en la inmortalidad del cangrejo (como casi siempre), recordé que tenía que hacer un trabajo para entregar. Abro el OpenOffice Writer y me dispongo a hacerlo. Todo normal, hasta que llega el momento de cambiar el formato.

Clico en la lista de fuentes y me doy cuenta de algo muy raro: no aparecen todas las que tengo instaladas. De hecho, no aparece ni la mitad. Mosqueado, verifico que el sistema todavía las reconozca. Abro las preferencias de apariencia de Gnome, sección tipografía y sí, allí están todas. Entonces, ¿que pasa?

Quise saber si sólo era del OpenOffice o de otras aplicaciones, así que instalé el AbiWord y me di cuenta de que igual, no aparecen todas. Ya muy mosqueado, me puse a investigar el por qué. Mensajes sobre como instalar las fuentes en Linux, como regenerar la caché para que el sistema las reconozca, etc. etc.

Nada. Vamos, que después de un buen de intentos, el sistema seguía igual. Me cansé, y lo dejé para ayer.

Entonces, me puse a trastearle al sistema a ver si ‘saltaba la liebre’.  Copié nuevamente los archivos de fuente a /usr/share/fonts y nada. Los copié entonces a /usr/share/fonts/truetype y nada. A /usr/share/fonts/truetype/openoffice y no. Y por último a /usr/lib/openoffice/share/fonts/truetype y adivinen qué: noup. Eso ya me estaba cabreando.

Busqué por aquí y por allá y me encontré ésta página, que si bien no me resolvió el problema, me dio pistas de como arreglarlo. Al hacer lo de la parte del programa spadmin, me dí cuenta de algo curioso: no me aparecían listadas las fuentes en el cuadro de agregar. Probé todas las carpetas donde las había copiado y en una de ellas me mostró… un archivo. Bueno, íbamos progresando ^__^. ¿Qué tenía de diferente ése archivo del resto que estaba en la misma carpeta? Fijándome bien, lo descubrí: tenía la extensión de archivo, es decir *.ttf. Y los demás no.

Revisé entonces un antiguo backup de Windows que tenía por allí y saqué los archivos de fuente que tenía y que todavía tenían su extensión. Borré todas las copias que había hecho en las carpetas y copié los del backup. Luego, hice un…

fc-cache -f -v

como root para regenerar el caché de fuentes y por si las dudas, reinicié la computadora…

¡Y alé! No me cargó el GDM (XD). Sólo me mostró un mensaje con un botón de ‘Aceptar’, aunque de hecho, esto sólo lo pude suponer, por que tanto mensaje como botón, estaban escritos con sólo cuadros. Para entonces, ya no sabía si reír o… reír. Y es que a enojarme no le ví mucho sentido, por que al fin, quien cometió la tarugada fui yo.

Vamos, que al parecer, por borrar las demás copias de las fuentes, se desgració algo en el GDM. Afortunadamente, pude iniciar las X y entrar gráficamente. Con eso copié un duplicado del conjunto de fuentes anteriores (no las del backup, de Windows, si no las del backup de Debian) nuevamente a /usr/share/fonts y otra vez recargué la caché. Reinicié nuevamente y ¡vualá! Sin problemas.

Abrí el OpenOffice, y ¡yeah! También solucioné el problema. Todas las fuentes salen y son reconocidas. Igualmente por el AbiWord.

Esta vez, vaya que me hizo sudar el Pingüino, me cae.

Pero eso sí, uno aprende… un montón. (Aunque no tengo idea si lo que hice es ‘recomendable’, ya que ahora muchas de las fuentes que tengo están duplicadas, pero los programas no listan los duplicados, así que supongo que mientras funcione…).

Reactivando una ‘Legacy PC’

junio 1, 2008 en 12:22 AM | Publicado en Liberación digital, Sucesos | 5 comentarios
Etiquetas: , ,

Hace algún tiempo le regalaron a mi hermana una computadora. Uno podría decir “¡vaya, le han regalado una PC, que suerte!”. De hecho, se la dieron por que, como adivinarán, no es precisamente una máquina muy nueva.

En sí, es un modelo Compaq de más o menos hace como nueve años. ¿Sus características? Unas muy, muy limitadas para lo de ahora:

– Procesador Pentium II a 400 MHz
– RAM de 32 MB (que luego doblé a 64)
– Disco duro de 3.9 GB
– Sin tarjeta Ethernet

Como véis, una reliquia ya. Algo para el basurero, dirían algunos. Y por supuesto, eso le pasaría si Windows fuera el único sistema operativo sobre la Tierra. Afortunadamente no es así, y gracias al sistema del Pingüino, esta PC puede tener nueva ‘vida’.

Ya lo había pensado mucho antes, pero hasta apenas hoy me vino la idea de investigar sobre qué distribuciones le quedarían mejor. Y me puse a evaluar: ¿Xubuntu? Para nada. Por mucho que digan que es para máquinas pasadas, tan solo el LiveCD necesita 256 MB para cargar. Por supuesto, puedo hacer una instalación en modo texto, pero según lo que he leído, Xfce también necesita algo más de RAM de la que tengo.

Ubuntu Lite me llamó la atención, pero su página no pone en claro los requerimientos mínimos, y además,  la imagen para descargar es de  693 MB, lo que no se me hace muy ‘lite’ que digamos (a lo mejor ya instalado no es tanto, pero no estoy de humor ahora como para bajar tantos MB, para colmo vía HTTP, que al parecer no tiene por BitTorrent).

Por supuesto, también chequé las mini-mini: Damn Small Linux y Puppy Linux. Ambas con lo que necesito para esta Compaq: ligeras, pequeñas en descarga y nada hambrientas de recursos. No obstante, al final me decanté por una no tan conocida: DeLi Linux. Basada en Slackware, y que puede funcionar en Pentiums de 133 MHz con 16 MB de RAM, se perfila como la que reanimará al ordenador en cuestión.

Lleva un set de programas muy light (Beaver, Gnumeric, AbiWord, Konq-e, etc.) y los manejadores de ventanas IceWM y Fluxbox. Por lo tanto, sus requerimientos son nimios.

Aún no lo he instalado, lo que haré mañana, pero según lo que he visto, me divertiré de lo lindo con él.

Crea un blog o un sitio web gratuitos con WordPress.com.
Entries y comentarios feeds.