Human Revelation Hybrid

diciembre 2, 2008 en 12:46 AM | Publicado en Debian, General, Los días nada interesantes | Deja un comentario
Etiquetas: , , , ,

Pues como dice Linuxman: “si no tienes nada que publicar… pues un screenshot” ^__^.

Human Revelation Hybrid 1

Human Revelation Hybrid 1

Human Revelation Hybrid 2

Human Revelation Hybrid 2

Éste es uno de los temas que más me ha gustado como me ha quedado, puesto que combina sencillez y claridad en un mismo tema.

El tema GTK es Clearlooks Classic, modificado en varios puntos con el programa GNOME Color Chooser.
El borde de ventana es Human Synergy, del GTK del mismo nombre.
El set de iconos es GNOME-Colors, variación Human.
El fondo de pantalla está incluído con el tema GTK Pucko Modern.

¿Y por qué le puse Human Revelation Hybrid? Por que el tema en sí lo cree usando el tema de iconos Oxygen-refit 2 Orange Version, que son más ‘modernos’, además de un fondo de pantalla fotográfico. Luego hice ésta mezcla, que al final me gustó más. Además, después de mucho estar combinando temas, y que al final ninguno me gustaba, me puse a jugar con las paletas de colores de varios de ellos, y dígamos que tuve una “revelación” al usar los tonos de naranja de los temas Human de Ubuntu y del motor Rezlooks.

Y el icono de la papelera regresó

septiembre 11, 2008 en 11:57 PM | Publicado en Debian, Lo que mola, Los días nada interesantes | Deja un comentario
Etiquetas: , ,

Hace ya tiempo me ocurrió un problemita muy raro acá en el Debian. Estaba acostumbrado a tener el icono de la papelera en el panel, para que no quitara espacio en el escritorio. De esa manera, además, podía mandar archivos a ella con sólo “arrastrar y soltar”. Muy práctico.

Pero un día, de buenas a primeras, el susodicho icono en el panel se fue. Ya no apareció. Reinicié el servidor gráfico, intenté agregar el applet de nuevo al panel, pero nada. O debo decir que sí que se agregaba, pero no se veía. El único indicio de que estaba allí era que podía abrirla con dar clic sobre una ínfima línea de 1 px en el panel. Pero nada de icono.

Busqué varios métodos para arreglarlo, pero ninguno funcionó. No obstante, hoy intenté añadirlo de nuevo, y ¡oh sorpresa! El mentado iconito apareció. Funciona bien y sin problemas, al parecer. Supongo que el milagro se lo debo a alguna actualización que haya hecho últimamente el sistema. En cualquier caso, regresó y eso hizo mi felicidad del día =3.

Y el pajillero icono volvió.

Y el pajillero icono volvió.

Squeeze: el sucesor de Debian Lenny

septiembre 2, 2008 en 6:40 PM | Publicado en Debian, Lo que mola, Webroll | Deja un comentario
Etiquetas: , , ,

Vía Barrapunto me entero que apenas ayer, Septiembre 1 de 2008 se ha decidido el nombre que tendrá la versión Debian que será la sucesora de Lenny.

Para los que no estén muy enteradillos (que lo dudo), os explico que la distribución Debian elige el nombre de sus releases en base a los de los personajes de Toy Story.

Después de Lenny (quien en la película eran los binoculares con pies), le ha tocado su turno a Squeeze, el nombre que reciben las hordas de alienígenas verdes con tres ojos que aparecen tanto en la primera como en la segunda películas (en la segunda me hicieron más gracia, por que los señores Cara de Papa los adoptan como hijos XD).

Debo decir que cuando leí el nombre, lo primero que me vino a la mente fue el pingüino asmático y de voz de Frank Sinatra de la segunda película, por lo que se me hizo algo muy ‘karmático’ (por el hecho de ser un pigüino). Pero luego recordé bien y no, pues el sujeto en cuestión se llama Wheezy. Habrá que esperar a que usen ése personaje.

Pues sea. Dentro de unos días ya no diré que uso Lenny, si no Squeeze. Se oye raro.

Otro problema resuelto

agosto 29, 2008 en 11:53 PM | Publicado en Debian, Liberación digital, Sucesos | Deja un comentario
Etiquetas: , , , , , , ,

Desde que uso Debian he de decir que he tenido que, ya sea por las buenas o por la malas, aprender mucho. De repente me han salido problemillas que he tenido que resolver “a pie”.

Como cuando se me congelaba completamente el sistema al usar Banshee, que después me enteré, era por que usaba el tema Aurora y éste provoca un error dentro de dicho programa. Con cambiar a otro tema o no usar Banshee, asunto arreglado.

O cuando por andar intentando arreglar lo de unas fuentes de OpenOffice.org, desgracié el GDM XD.

Pues ahora me ha salido otra cosa. Por andar poniendo el engine Rezlooks y, supongo, sobrecargar de temas el Gnome, se me borraron las previsualizaciones del gestor de temas. Sólo se veía una lista con muchos, muchos signos de interrogación. Claro, no es algo ‘vital’ para que funcione el sistema, pero luego me dí cuenta de que tampoco funcionaban otras cosas. El Metacity, si lo intentaba cambiar, congelaba el sistema, y al reiniciarlo, ninguna ventana tenía borde. Un problemón, como quien dice.

Afortunadamente pude ya solucionarlo (o eso parece). Tuve que hacerlo del modo difícil. Borrar tooodo lo central de Gnome (gnome-core, gnome-desktop, metacity, etc.) y luego reinstalar paquete por paquete. Tedioso, lo sé. Al fin me dí cuenta donde estaba el problema. En el paquete gnome-themes-extras. Si lo ponía ya no rulaba, si lo quitaba, funcionaba de nuevo.

Lo quité y ya. Al fin sólo me pierdo de unos cuantos temas que ni uso. Aunque eso sí, esta vez no tuve ni pajolera idea de donde madres estuvo el problema. No creo que haya sido Metacity ni el GTK. Tampoco se me hace que haya sido el Rezlooks, ya que lo he vuelto a poner y funciona bien. A lo mejor es por que ya eran muchos temas o algo así. Primer problema en GNU/Linux que no sé de que va.

Claro, no puedo despotricar contra la distro. Al fin y al cabo estoy en testing y siempre hay la posibilidad de que esto pase. Si estuviera en estable, no me pasarían estas boludeces y el mundo feliz. Pero habemos algunos que nos gusta la mala vida XD.

ZSNES y el sonido en GNU/Linux

junio 29, 2008 en 1:06 AM | Publicado en Consejos y utilidades, Debian, Sucesos | 21 comentarios
Etiquetas: , ,

El SNES ha sido siempre una de mis consolas de videojuego favoritas. No obstante, nunca pude conseguir varios juegos que me gustaron mucho en su tiempo. Afortunadamente, gracias a la computadora y un emulador, es posible jugar ésos juegos sin necesitar la consola real.

Desde que usaba Windows, el programa ZSNES ha sido mi preferido para hacerlo. Cuando migré a GNU/Linux supuse que no habría versión para éste sistema y ya me había resignado a ello. Agraciadamente, el programa sí que está disponible y funciona muy bien, debo decir. Cuando lo instalé en Fedora no tuve problemas para usarlo. Pero hoy, en Debian, me dí cuenta de que a pesar de que el programa estaba bien instalado y no parecía haber algún problema aparente, no me daba sonido. Los juegos no se escuchaban en absoluto.

Verifiqué configuración aquí y allá. Y después me puse a googlear alguna respuesta. Algunas personas recomendaban bajar la resolución de la ventana, y otras usar OSS en vez de ALSA. No me funcionó ninguna de esas recomendaciones. Seguí buscando y di con la solución.

El problema, al parecer está en el archivo de configuración del emulador que se encuentra en /home/user/.zsnes. Allí se encuentra el archivo zsnesl.cfg, el cual hay que editar para que funcione el sonido. Al abrirlo (se puede hacer sin estar como root, puesto que el fichero en cuestión está en nuestro Home) hay que buscar el apartado que se refiere al sonido (‘Sound’). El inicio del apartado luce así:

; —-
; — Sound —
; —-

; libAO driver to use. Use zsnes –help to see valid list.
; However “auto” (to automatically pick best one), and “sdl” should
; always be available.
libAoDriver=”auto”

Aquí, entonces, hay que cambiar la línea que no está comentada (la que no tiene punto y coma), es decir, la que dice libAoDriver. Como ven, el valor que tiene es auto (así era en el caso del mío). Hay que cambiar ése auto por sdl, con lo que le diremos al emulador que use ALSA en vez de intentar buscar automáticamente un controlador adecuado. Debe entonces de quedar así:

; —-
; — Sound —
; —-

; libAO driver to use. Use zsnes –help to see valid list.
; However “auto” (to automatically pick best one), and “sdl” should
; always be available.
libAoDriver=”sdl

Guardamos el archivo y lo cerramos. Abrimos ZSNES y en teoría debe funcionar. Si no lo hace, hay que asegurarse de tener instalada la librería libsdl1.2.debian-alsa (supongo que lo de ‘debian’ varía según la distribución usada, pero no tengo manera de comprobarlo).

Y pues eso es todo. A mí me funcionó y ahora ya tengo sonido en el emulador. Así que a recordar mis viejos tiempos con el Super Mario World =3.

Video y el gestor de composición de Metacity

junio 21, 2008 en 12:10 AM | Publicado en Debian, Lo que no mola, Sucesos | 4 comentarios
Etiquetas: , , , ,

Creo que a estas alturas ya no es un secreto que Metacity, el gestor de ventanas de Gnome, puede manejar lo que se conoce como ‘composición’. Es decir, esos efectos llamados “eye candy”. Ya saben: sombras, transparecias, etc.

Pero para los que todavía anden un poco perdidos, es muy fácil probar esta característica. Sólo abren el editor de configuración de Gnome (gconf-editor) y buscan la clave /apps/metacity/general. Y activan la opción de compositing_manager. ¡Y vualá! Sombritas, algunas transparencias y cosillas así se activarán. No hay que esperar algo como Compiz, pero se ve bien.

No obstante, hoy me dí cuenta de algo. Si quiero reproducir un vídeo en Totem o MPlayer con el compositing activado no se ve nada. De hecho, sólo moviendo la ventana se ve el vídeo, pero no me voy a poner a mover la ventana en lo que dura el vídeo, ¿verdad?

De momento no he encontrado alguna solución, y de momento he desactivado el gestor de composición. Lo raro es que tengo idea de que antes sí que podía mantenerlo activo y ver vídeos, pero ya no me acuerdo bien. Si no, tendré que cambiar de gráfica.

Lástima, me gustaba como se veía.

Actualizo:

He encontrado el problema que impedía que los vídeos se vieran con el gestor de composición de Metacity activo. Eso ocurre cuando se usan las librerías GStreamer (por ejemplo, con el paquete totem-gstreamer). Pero si se cambia a las librerías de Xine (p. ej.: totem-xine) no ocurre. Mi solución fue desinstalar el totem-gstreamer y sólo dejar el totem-xine. No he checado si con MPlayer u otros funciona, pero de momento, es lo único que quería.

Página siguiente »

Blog de WordPress.com.
Entries y comentarios feeds.