Un problema lleva a otro

junio 20, 2008 en 12:49 AM | Publicado en Debian, Liberación digital, OMG, Sucesos | 3 comentarios
Etiquetas: , , , , , , , ,

Antier, mientras estaba pensando en la inmortalidad del cangrejo (como casi siempre), recordé que tenía que hacer un trabajo para entregar. Abro el OpenOffice Writer y me dispongo a hacerlo. Todo normal, hasta que llega el momento de cambiar el formato.

Clico en la lista de fuentes y me doy cuenta de algo muy raro: no aparecen todas las que tengo instaladas. De hecho, no aparece ni la mitad. Mosqueado, verifico que el sistema todavía las reconozca. Abro las preferencias de apariencia de Gnome, sección tipografía y sí, allí están todas. Entonces, ¿que pasa?

Quise saber si sólo era del OpenOffice o de otras aplicaciones, así que instalé el AbiWord y me di cuenta de que igual, no aparecen todas. Ya muy mosqueado, me puse a investigar el por qué. Mensajes sobre como instalar las fuentes en Linux, como regenerar la caché para que el sistema las reconozca, etc. etc.

Nada. Vamos, que después de un buen de intentos, el sistema seguía igual. Me cansé, y lo dejé para ayer.

Entonces, me puse a trastearle al sistema a ver si ‘saltaba la liebre’.  Copié nuevamente los archivos de fuente a /usr/share/fonts y nada. Los copié entonces a /usr/share/fonts/truetype y nada. A /usr/share/fonts/truetype/openoffice y no. Y por último a /usr/lib/openoffice/share/fonts/truetype y adivinen qué: noup. Eso ya me estaba cabreando.

Busqué por aquí y por allá y me encontré ésta página, que si bien no me resolvió el problema, me dio pistas de como arreglarlo. Al hacer lo de la parte del programa spadmin, me dí cuenta de algo curioso: no me aparecían listadas las fuentes en el cuadro de agregar. Probé todas las carpetas donde las había copiado y en una de ellas me mostró… un archivo. Bueno, íbamos progresando ^__^. ¿Qué tenía de diferente ése archivo del resto que estaba en la misma carpeta? Fijándome bien, lo descubrí: tenía la extensión de archivo, es decir *.ttf. Y los demás no.

Revisé entonces un antiguo backup de Windows que tenía por allí y saqué los archivos de fuente que tenía y que todavía tenían su extensión. Borré todas las copias que había hecho en las carpetas y copié los del backup. Luego, hice un…

fc-cache -f -v

como root para regenerar el caché de fuentes y por si las dudas, reinicié la computadora…

¡Y alé! No me cargó el GDM (XD). Sólo me mostró un mensaje con un botón de ‘Aceptar’, aunque de hecho, esto sólo lo pude suponer, por que tanto mensaje como botón, estaban escritos con sólo cuadros. Para entonces, ya no sabía si reír o… reír. Y es que a enojarme no le ví mucho sentido, por que al fin, quien cometió la tarugada fui yo.

Vamos, que al parecer, por borrar las demás copias de las fuentes, se desgració algo en el GDM. Afortunadamente, pude iniciar las X y entrar gráficamente. Con eso copié un duplicado del conjunto de fuentes anteriores (no las del backup, de Windows, si no las del backup de Debian) nuevamente a /usr/share/fonts y otra vez recargué la caché. Reinicié nuevamente y ¡vualá! Sin problemas.

Abrí el OpenOffice, y ¡yeah! También solucioné el problema. Todas las fuentes salen y son reconocidas. Igualmente por el AbiWord.

Esta vez, vaya que me hizo sudar el Pingüino, me cae.

Pero eso sí, uno aprende… un montón. (Aunque no tengo idea si lo que hice es ‘recomendable’, ya que ahora muchas de las fuentes que tengo están duplicadas, pero los programas no listan los duplicados, así que supongo que mientras funcione…).

Anuncios

3 comentarios »

RSS feed for comments on this post. TrackBack URI

  1. Frente a un susto así, yo lo más seguro es que hubiera formateado…aunque también, yo no sé ni medianamente tanto, y además, no uso Debian, asique me imagino que me resulta más fácil restaurar las dos o tres cosas que tengo que restaurar cuando formateo. Otros preferirían mantener el formateo anterior a toda costa >_>;

    Será que todos los sustos de muerte con la pc se originan en problemas tontos? Recuerdo que no me asusté ni tanto la vez que eliminando un virus, mi AV me borró el win.ini en el proceso…

  2. Pues depende. Yo desde hace tiempo me hice a la idea de que esto no es Windows, y que no puedo depender del formateo siempre.

    Además, como esto no es Windows, sé perfectamente que hay una o varias soluciones para cualquier problema (excepto con las cosas del hardware incompatible).

    El único problema es encontrar esas soluciones…

  3. […] cuando por andar intentando arreglar lo de unas fuentes de OpenOffice.org, desgracié el GDM […]


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Blog de WordPress.com.
Entries y comentarios feeds.

A %d blogueros les gusta esto: